FreeFileSync not recognizing file on a virtual cloud drive

Get help for specific problems
Brooke
Posts: 1
Joined: 14 Aug 2019

Post by Brooke • 15 Aug 2019, 14:28

I have a 10GB collection of files all subordinate to a single directory. I have several copies of this structure that I have been synchronizing with FreeFileSync. Recently, I moved the main copy of the structure to a pCloud virtual drive so that I could share the files with my son who lives overseas. The two of us successfully use these files on the virtual drive via a genealogy program that I wrote. My son uses Mac OS, I use Windows and Linux. However, when I try to sync with FreeFileSync, its Compare function does not find any files on the virtual drive and wants to copy all the files from the local hard drive to the virtual drive. I tried both ‘File time and size’ and ‘File content’ with no change in results. I am using version 10.14, but also tried two older versions. All three versions failed to recognize the files on the virtual drive (all testing done on Windows 10). I thought if I copied the file structure from the virtual hard drive to a local hard drive, I would be able to sync and copy the updated main copy back to the virtual drive. Wrong! FreeFileSync even fails to recognize the files on the local hard drive that were copied from the virtual drive. I tried using FreeFileSync to sync two old copies of this file structure, and it worked correctly, as expected. Those two copies of the file structure have never resided in the virtual drive. It would appear that something has changed in the file system control information of files that have been on a virtual drive that throws FreeFileSync off. Does anyone know what is going on here?