[Feature request] RTS to remember "Idle Time"

Discuss new features and functions
The_Joker
Posts: 5
Joined: 29 Oct 2019

Post by The_Joker • 20 Nov 2019, 21:52

Hallo,

RTS always starts with an idle time of 10 seconds even if it was changed in the previous run.

It would be nice if it could remember the idle time set in the last run when it is started newly.

xCSxXenon
Posts: 185
Joined: 11 Jun 2019

Post by xCSxXenon • 20 Nov 2019, 23:07

A default option could be nice

User avatar
Plerry
Posts: 762
Joined: 22 Aug 2012

Post by Plerry • 21 Nov 2019, 07:58

When you save an RTS monitoring job (as an *.ffs_real-file),
the idle time setting is saved with it and is effective when opening that job.
But (obviously) it does not change the default idle time of any new RTS jobs.
Last edited by Plerry on 25 Nov 2019, 12:12, edited 1 time in total.

The_Joker
Posts: 5
Joined: 29 Oct 2019

Post by The_Joker • 24 Nov 2019, 19:19

Thanks for the tip @Plerry !

The_Joker
Posts: 5
Joined: 29 Oct 2019

Post by The_Joker • 01 Dec 2019, 23:10

When you save an RTS monitoring job (as an *.ffs_real-file),
the idle time setting is saved with it and is effective when opening that job. Plerry, 21 Nov 2019, 07:58
Well maybe it should do so, but it does not. I have set the idle time setting to 60 seconds and saved it as *.ffs_real file, but it has no effect, idle time is still 10 seconds, I checked it with the stopwatch.

For me this is an disadvantage, don't know what others think.

User avatar
Plerry
Posts: 762
Joined: 22 Aug 2012

Post by Plerry • 02 Dec 2019, 12:07

If you examin the *.ffs_real file with a text-editor (e.g. Notepad++),
it should contain (and in my case does contain ...) the XML line
<Delay>60</Delay>
(assuming you changed the idle time from 10 into 60 seconds).
If you run that RTS job and look at its settings (the Configure option of the RTS task in the task-tray), it also shows the 60 seconds rather than the default 10 seconds idle time.
When making a change to the monitored folder, the action also only takes place after 60 seconds idle time.
(RTS build 09/17/19 - Unicode x64, running on Win 10, version 1903)

Are you sure you invoke RTS passing the stored *.ffs_real file?
Look at the purple background text in the RTS Manual Section.
It seems you are using the second option, i.e. passing an *.ffs_batch file (the 3rd bullet), instead of passing your *.ffs_real file (the 2nd bullet).