please allow to change FTP timeout duration

Get help for specific problems
Posts: 2
Joined: 13 Sep 2018

Post by sylvainf • 13 Sep 2018, 10:30


I am syncing files between 2 Windows 2012 servers, with a FTP connection. The remote server has a slow RAID array.
FreeFileSync gives a lot of errors : « CURLE_OPERATION_TIMEDOUT: FTP response timeout »

Using Filezilla FTP client, I was able to confirm that the following things happen :
  • the client sends the data to the server (for example a 2 GB file)
  • the client is done sending data
  • the FTP server calls the "FlushFileBuffers" Windows API function
  • flushing the buffer takes more than 10 seconds, sometimes more than 1 minute
  • by setting the Filezilla Client timeout to a large value (300 seconds), I was able to successfully upload files with it
  • with FFS as a client, FFS waits 10 seconds after it's done sending data, then it opens a new connection to the server and checks the remote file size. The file size is zero, because the buffers are still in the process of writing to disk. So that file transfer is marked as failed.
This problem could be solved by having a larger timeout duration, with a setting in the GUI, instead of having it hardcoded. Could you please add an option for this ?

User avatar
Site Admin
Posts: 4927
Joined: 9 Dec 2007

Post by Zenju • 02 Oct 2018, 16:15

Done. Timeouts for FTP and SFTP connections can now be entered in the cloud folder picker. Let me know if there are any issues:

Posts: 4
Joined: 27 Jun 2018

Post by MarkB • 02 Oct 2018, 17:57

This Beta version is working for me. I set the timeout to 120 seconds and ran it against a series of folders containing roughly 50000 files each and it pulled the directory listings correctly for the comparison phase and it is currently running the sync portion, which appears to to be progressing correctly.

Posts: 2
Joined: 13 Sep 2018

Post by sylvainf • 03 Oct 2018, 14:58

Transfer completed successfully =)
This solved my problem, thanks a lot !