Error code 13 permission denied for remote sync

Get help for specific problems
gogreen1
Posts: 42
Joined: 6 Dec 2017

Post by gogreen1 • 10 Oct 2018, 21:32

I'm getting Error Code 13 permission denied when I try to sync to my MacBook Air over my home network. The Pictures folder on the MacBook shows the error. All other folders on the MacBook sync just fine, and they all have the same permissions. I don't see an option on the MacBook's System Preferences > Security & Privacy > Privacy > Full Disk Access to allow FFS on my iMac access.

Any ideas on how to solve this problem?

Falconer
Posts: 1
Joined: 11 Oct 2018

Post by Falconer • 11 Oct 2018, 01:47

Go to System Preferenences --> Security & Privacy --> Privacy.

Click the lock icon at the bottom left to unlock the preference pane and enter your admin credentials when prompted.

On the left column, scroll to find Full Disk Access and click on it.

Then, on the right, click the "+" icon and browse to find the FreeFileSync.app (probably located in your Applications folder)

Once FFS is in the list on the right side of that dialogue, you can quit System Preferences, quit FFS if it is open, relaunch FFS, and it will have the permissions it needs.

gogreen1
Posts: 42
Joined: 6 Dec 2017

Post by gogreen1 • 11 Oct 2018, 13:02

Thanks, Falconer. Yes, I've done this to get FFS to work again on my iMac after updating to Mojave, but I sync the files from my iMac to my MacBook Air via my home network. FFS isn't installed on the MacBook Air, so how do I get FFS to work again with that one folder on the MacBook Air? Works fine with my other folders. What am I missing? Thanks.
You do not have the required permissions to view the files attached to this post.

gogreen1
Posts: 42
Joined: 6 Dec 2017

Post by gogreen1 • 14 Oct 2018, 02:23

After a lot of experimentation, I got this task working again. I had to redo the directory permissions, and I instructed FFS to bypass the offending directory--I don't include anything in it, anyway.

larsmula
Posts: 1
Joined: 13 Feb 2019

Post by larsmula • 13 Feb 2019, 18:00

i spent so much time with this issue - i am not a coding expert and i even started looking at other software - but i kept coming back to this one as being the best alternative fee software for my purposes. Nothing - no luck - same error- same nightmare.

Then in the end i tried something --- i went to disk utility and reformatted the harddrive in the recommended Mac format and it worked - no permission error and i am now in the process of mirroring 7tbs of files. unfortunately it will mean erasing all the files on your HD but if you are like me and bought a new HD for the purpose of this exercise i hope this method works and will save you 3 hours of troubleshooting like I have just done.

I am assuming that if you have a PC and the same error arises it may be that again the HD needs to be formatted in the appropriate way. anyway hope this helps