Starting RealTimeSync automatically on Windows 11

Discuss new features and functions
Posts: 13
Joined: 15 Feb 2024

severy

I recently moved from a Windows 7 desktop computer to a Windows 11 laptop computer and I'm having trouble getting RealTimeSync to start up automatically on the Windows 11 laptop. Following other advice that I found on this forum, I copied the xxx.ffs_real file to the "shell:startup" folder. But when I reboot the computer, RealTimeSync is not started up automatically. I have verified that the ffs_real file is configured properly as I can start it manually after rebooting the computer and it runs properly and monitors the configured directories and calls FreeFileSync properly. It's only the boot startup step that isn't working properly.

I'm assuming that it's some kind of permissions problem, but I can't find any information on how to troubleshoot the problem. Is there any kind of logging for running RealTimeSync at boot startup on Windows 11 that I can look at to find any errors encountered during the startup process? I see log files for FreeFileSync, but nothing for RealTimeSync and nothing regarding logging for shell:startup scripts.
User avatar
Posts: 3593
Joined: 11 Jun 2019

xCSxXenon

This isn't likely a FFS/RTS problem.
Can you get anything to autostart by putting it into that startup folder?
Posts: 13
Joined: 15 Feb 2024

severy

I'll test that the next time I can shut everything down and reboot the computer. Is there any logging in Windows 11 about any startup issues? I dug through the Event Viewer logs but couldn't find anything relevant.
User avatar
Posts: 3593
Joined: 11 Jun 2019

xCSxXenon

There is not. There may be entries in Event Viewer if it is successfully trying to start but then RTS encounters an error. This is very unlikely though since you are able to go into the startup folder and start it manually
Posts: 13
Joined: 15 Feb 2024

severy

I was able to put a shortcut to a different application in the startup folder and it started up automatically. So this does seem to be specific to RTS. I'll keep digging to see if I can figure out what is going on.
User avatar
Posts: 3593
Joined: 11 Jun 2019

xCSxXenon

How do you know it isn't starting up? For me, it shows in the system tray on the taskbar. Have you checked there?
Posts: 13
Joined: 15 Feb 2024

severy

Yes, I checked in the system tray. It shows up there when I run the shortcut manually after the computer has booted. But nothing ever shows up when placed in the startup folder.
User avatar
Posts: 3593
Joined: 11 Jun 2019

xCSxXenon

Can you post a screenshot of the startup folder in File Explorer?
Make sure the path is fully visible, or copy/paste the full path here.
Posts: 13
Joined: 15 Feb 2024

severy

The path is "C:\Users\sever\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup". The shortcut is named "GoogleDriveSync" with a Target of "C:\Users\sever\Documents\GoogleDriveSync.ffs_real". I can't find a way to post a screenshot in this reply, however.
Posts: 13
Joined: 15 Feb 2024

severy

I made the following additional changes this morning, still without a positive result:

1) I changed the "Run" option on the .ffs_real shell:startup shortcut to "Minimized".
2) I found that the "Run as administrator" option for the shortcut is greyed out because it's pointing at the .ffs_real file, not an actual executable.
3) I changed the Compatibility properties for the RealTimeSync.exe executable in the "Change settings for all users" dialog to:
a) Run this program in compatibility mode for: Windows 7 (since I previously had all of this running successfully on Windows 7)
b) Run this program as an administrator

When I rebooted the laptop, RTS still did not start up automatically.
User avatar
Posts: 2278
Joined: 22 Aug 2012

Plerry

> I can't find a way to post a screenshot in this reply

See e.g. here
Posts: 13
Joined: 15 Feb 2024

severy

Thanks, Plerry!

Here is the screenshot:
Screenshot 2024-02-18 095400.png
You do not have the required permissions to view the files attached to this post.
User avatar
Posts: 3593
Joined: 11 Jun 2019

xCSxXenon

Try putting the .ffs_real file directly in the startup folder, instead of a shortcut
User avatar
Site Admin
Posts: 7051
Joined: 9 Dec 2007

Zenju

A shortcut should suffice if created properly: https://freefilesync.org/manual.php?topic=rts-as-service
Posts: 13
Joined: 15 Feb 2024

severy

I have tried it both ways, first putting the .ffs_real file directly in the startup folder, and then next as a shortcut. Both with the same negative results.
User avatar
Site Admin
Posts: 7051
Joined: 9 Dec 2007

Zenju

A shortcut to the exe obviously, not ffs_real.
User avatar
Posts: 3593
Joined: 11 Jun 2019

xCSxXenon

I'm inclined to blame your Windows installation at this point lol
Might be worth running a repair install
Posts: 13
Joined: 15 Feb 2024

severy

I put a shortcut to the FreeFileSync executable in the shell:startup folder, and updated the Target to include the ffs.real file as the command-line parameter, as follows:

"C:\Program Files\FreeFileSync\RealTimeSync.exe" C:\Users\sever\Documents\GoogleDriveSync.ffs_real

I set the shortcut to Run as Minimized and to Run as Administrator

After a reboot, it still will not startup automatically. I can later manually run the shortcut from the shell:startup folder and RTS is loaded and runs properly after that, so the shortcut appears to be configured properly.
Posts: 7
Joined: 18 Feb 2024

njroute22

Did you try it with a batch config as well?
User avatar
Posts: 3593
Joined: 11 Jun 2019

xCSxXenon

Did you try it with a batch config as well? njroute22, 18 Feb 2024, 23:30
This is an irrelevant suggestion as RTS only works with .ffs_real configuration files
Posts: 7
Joined: 18 Feb 2024

njroute22

It works with both batch files and real files per FFS manual:

Image
Posts: 13
Joined: 15 Feb 2024

severy

Ok, now I'm starting to get somewhere. njroute22, I had previously tried a batch file in the startup folder without success, but it might not have been configured properly. So based on your suggestion, I decided to give it another try. I created the file RealTimeSync.cmd and placed it in the shell:startup folder with the following contents:

"C:\Program Files\FreeFileSync\RealTimeSync.exe" C:\Users\sever\Documents\GoogleDriveSync.ffs_real

When I rebooted the laptop, a command prompt window was displayed, as follows:
Screenshot 2024-02-19 110437.png
And when I checked the taskbar, RTS was running!

The only remaining issue, however, is that the command prompt window did not close. I had to close it manually (although RTS did remain running, fortunately).

Why is the command prompt window staying open when running a batch file in the startup folder and how can I get it to automatically close once the command has been run?
You do not have the required permissions to view the files attached to this post.
User avatar
Posts: 3593
Joined: 11 Jun 2019

xCSxXenon

Add start "" xxxxxx before the RTS command so it looks like:

start "" "C:\Program Files\FreeFileSync\RealTimeSync.exe" C:\Users\sever\Documents\GoogleDriveSync.ffs_real

Add "exit" to the cmd script you created
I stand corrected on njroute22's suggestion!
Posts: 13
Joined: 15 Feb 2024

severy

xCSxXenon,

That's exactly what it took to get it to work, thanks! I first tried just adding "exit" as a second line in the batch file, but it never got to that line. But using "start" to run RTS did the trick and everything is now working completely.

Thank you to xCSxXenon, Plerry, Zenju, and njroute22 for all of your excellent advice and suggestions! I hope this thread will help someone else who runs into the same challenges that I did.