SFTP connection error for any port other than port 22

Get help for specific problems
thespartan
Posts: 5
Joined: 8 Jul 2020

Post by thespartan

Hi

I'm using version 10.24 [Donation Edition] Windows 10 64 Bit (17/05/2020) to sync files over SFTP between Windows 10 to Ubuntu server 18.04 LTS.

Syncing has been working up until recently when I changed the ssh port to 2222 on the server, naturally I updated the SFTP details to include the new port but it fails to connect.
You do not have the required permissions to view the files attached to this post.
simbun
Posts: 17
Joined: 4 May 2020

Post by simbun

I just tried from Windows 10 (FFS 10.25) to Raspbian and Ubuntu 18.04 and changing the port to 2222 worked fine for me.
I trust you restarted ssh?

Have you tried another program e.g. WinSCP?
thespartan
Posts: 5
Joined: 8 Jul 2020

Post by thespartan

I just tried from Windows 10 (FFS 10.25) to Raspbian and Ubuntu 18.04 and changing the port to 2222 worked fine for me.
I trust you restarted ssh?

Have you tried another program e.g. WinSCP? simbun, 08 Jul 2020, 14:10
Thanks I did restart ssh, I also tried WinSCP and it worked like a charm no issues whatsoever. At first I thought it was ufw so I disabled it but even with ufw disabled it makes no difference I still get the same error.

I might give FFS 10.25 a whirl and see if it's any better.
simbun
Posts: 17
Joined: 4 May 2020

Post by simbun

I just tried with Raspbian and 10.24 and it worked fine on port 2222.

If I try and connect on an incorrect port I receive the following message:
img.jpg
Given that your message is different, yet you've disabled the firewall (I'm not running one) and WinSCP is working I'm at a bit of a loss. Hopefully someone more knowledgeable will be able to help.
You do not have the required permissions to view the files attached to this post.
thespartan
Posts: 5
Joined: 8 Jul 2020

Post by thespartan

I just tried with Raspbian and 10.24 and it worked fine on port 2222.

If I try and connect on an incorrect port I receive the following message:
img.jpg

Given that your message is different, yet you've disabled the firewall (I'm not running one) and WinSCP is working I'm at a bit of a loss. Hopefully someone more knowledgeable will be able to help. simbun, 08 Jul 2020, 14:57
Thanks I really appreciate the effort, I'm going to try FFS 10.25 and will report back as to whether it resolves the issue.
thespartan
Posts: 5
Joined: 8 Jul 2020

Post by thespartan

Same issue for FF1s 10.25 :(
thespartan
Posts: 5
Joined: 8 Jul 2020

Post by thespartan

Same issue for FFS 11.0 as well
simbun
Posts: 17
Joined: 4 May 2020

Post by simbun

The fact that it worked for me, combined with the lack of support here would suggest that it may be a problem your end.
When you try and connect do you see anything in /var/log/auth.log?
I assume you've disabled any Windows firewall/HIPS you have running?

I haven't tried it and I don't know what the output looks like, but you could try using Process Monitor to trace the problem https://freefilesync.org/faq.php#trace